Jan 11, 2013

Foxit vulnerability

Third party PDF reader, Foxit, is currently vulnerable to a critical exploit.

Until Foxit release a fix which limits the length of URLs your best protection is either to avoid PDF files, or downloaded them before opening. Do not use Adobe Acrobat Reader instead.

Sadly too many PDFs are deployed instead of the original, open, document formats eg. RTF, plain text, HTML etc. Convenience comes at a price.